WebDAV Server Update

We have released a huge update to the WebDAV protocol server!

Changes and fixes include:

  • New, more powerful server
  • New software stack
  • Improved connection handling and timeouts
  • Hidden, system and temporary file filters to increase performance
  • Initial WebDAV Sync support
  • Timezone reconfiguration
  • Fixed unicode support for filenames
  • Content types handled correctly

Everything is now live - No need to change anything in your clients.

We will continue to monitor and tweak things accordingly and listen to your feedback also.

Providing all is well and there is demand, we can also introduce new geographic locations for WebDAV too.

Enjoy the update!


Sweet! Thank you! WebDAV do be very useful at times!

1 Like

That sounds supercool!

Works really nicely so far, I do wish you guys would’ve given a heads up though that you’re working on it, otherwise I see the same problems reported here and no responses.

FYI, WebDAV also seems to work with tools like Kopia now, through rclone that is.
Good job team, @Chris @JimmyB .

I do still worry about file sync through the network drive, I hope that’s the next thing to be remedied, it seems there’s no handling for big filecounts and the caching goes wild.


Thanks for the feedback, glad it’s working well!

Yes, sync is a main priority of ours, we have actually implemented an all new solution to do a virtual folder app which we are yet to release, infact it needed it to function properly.

So our goal is to use what we learned with testing this app to repair the live sync :slight_smile:


How did you manage to get it to work with rclone? I get this error when i try to create a repo:
connect error: unable to write blobcfg blob: PutBlob() failed for “kopia.blobcfg”: error writing blob using WebDAV: unable to complete WriteTemporaryFileAndCreateParentDirs despite 10 retries: BLOB not found



Yeah It’s been 100% fine for me after the WebDAV update.
Also try something like version 1.60.1 of Rclone, some newer update broke things for me and I’m not sure if it’s been fixed. rclone-v1.61 does not work anymore with kopia · Issue #2655 · kopia/kopia · GitHub

Try creating the directory beforehand in the non-encrypted section, Kopia may have trouble creating one from scratch, sometimes it does it well, then for some cloud providers it doesn’t.
Then whatever you called the IceDrive connection in your Rclone config use that name and directory separated by colon.

So I called my config in rclone “ice”, I’d use something like “ice:enc” in the path for Kopia, enc being the directory I made in Icedrive.

I’m almost certain you have the rclone issue.

1 Like

Yeah, with old versions of rclone works like a charm. Thank you for the info.
Have you tried moving TBs of data thru Kopia/WebDAV since the new server ? I know i got some “Maximum backoff reached” errors on the old one due to excessive network requests.
Are those limits still in place @JimmyB ?


@spxjet I don’t have TBs of data, but I do backups of 100-200GB at a time per week and haven’t had any issues anymore.

Speeds are still better than almost all services.

1 Like

i’m having some issues since 2-3 days accessing data with webdav and syncing with rclone… are you updating something?
thanks in adavance

1 Like

are there any long-term experiences with larger amounts of data via Webdav? in the past it was always a disaster. does Synology Backup work with Icedrive Webdav? I’m considering getting Icedrive


I had some problems since webdav server update. My note app Joplin have some errors on sync.

Error: Could not upgrade from version 1 to version 2: PUT info.json: Unknown error 2 (429): You have been temporarily rate limited.

Is this update or a new setup server should be responsible about this error ? I see a rate limited. A precedent error was a timeout issue.

1 Like

I am receiving the same error using Icedrive as a Webdav storage for Zotero papers.

1 Like

It’s a setup problem on webdav servers. The rate is limited. @IcedriveSupport Can you tell us when this rate will be fix ? Any update ?
@JimmyB #bug-reporting #release-logs

Hi, unfortunately it still stuck in the 429 error with rate limited. I use webdav just for joplin sync -a note app- on desktop and mobile device
@JimmyB #bug-reporting

Since the webdav server update I can no longer play madia files via webdav on android. When I try to play song I get a “connection lost” error through various players including VLC. Playback works fine from the native icedrrive app but the app doesn’t move automaticaly from on song to the next. Can this be fixed in a future update please? Already logged in a ticked with no positive outcome yet.


Hello, I signed up for the paid plan recently. I am trying to sync my zotero library using webDav. I get the following error. Is there a work around or a fix for this?

“An unknown error occurred.
Please check your file sync settings or contact your WebDAV server administrator.
HTTP 429”

I see some users in this thread also reported the same error. All helpful suggestions are welcome.


Hi @hari ,
Icedrive dev team is working on this issue. It’s a major update (V3). And it will come asap. But actually it’s in beta version. This issue on webdav is about rate limitation. It will be fix in few days/weeks normally.

1 Like

I am having the exact same problem. I initially was able to connect Zotero with no problem but suddenly it stopped working. This is the main reason I paid for Icedrive for 12 months.

It is not a problem with WebDav itself as I can map the network drive in Explorer in windows 10 with no problem. If they can identify where the traffic is coming from this would suggest they are blocking Zotero sync directly.

Very tempted to seek a refund as it is no longer any use to me

1 Like