Update v.2.73 not working propperly?

Yesterday, an update to 2.73 was installed for Icedrive,
Since then, the mounted drive on Windows 10 is stucking periodically!
I cannot open or save files because it stops working. I can see a red dot on the icedrive icon in the taskbar, the transfer “window” shows me a file with 1K is still not transmitted.
All programs working on files saved on Ice drive are frozen.
Closing Icedrive is not possible, the only way to stop Icedrive is to end the task via task manager.
If Icedrive is “closed” all programs stop from freezing and are working again.
Is there anything not working properly???

Would it be possible for you to email the drive app log to support@icedrive.net so that our dev team can take a look and see what may be the cause of the freezing with the new version so that it can be resolved as quickly as possible?


Same issue here this morning. programs that wer using icedrive froze.
BUT at that point in time I was still on 2.72.


Transfer failed:
no response to server

this is the only message I get!
I have saved a lot of files, none of them is saved at all on ice drive???

Our dev team have just made some amendments to the file servers that may have prevented uploads from the mounted app. Let us know if you’re still experiencing these issues.

I had similar issues this morning with v2.73, but things seem to be back to normal now.

Brilliant :slight_smile:. Let us know if you experience any more issues.

Moral of the story is never update to a new version of software for at least 14 days, let other people experience the problems first…

1 Like

I have the same issue. When updated yesterday, the app on Windows is not working properly. When trying to copy a file to the I: drive, it gets stuck, freezes, and cannot close the Windows app or just finish the never ending sync… Can do only via (getting to the) task manager

1 Like

Let’s suppose… you MOVE a file to the drive I: (cloud).
It does not sync, gets into the error above.
It does not update the cloud and the file simply disappears.
It is not at the origin because you moved it, neither at destination (sync error).
That was the issue I had…
It should never happen…

Yes, this was a similar issue for me also, so the files I created and “saved” to Ice drive just disappeared.
They were not saved on my hardrive and never reached the “cloud”

Similar issue for the records. I updated to v2.73 on windows this morning and when attempting to save files to my mounted drive, the system would freeze and eventually I would get the following error message: “.… (filepath) is not accessible. Insufficient system resources exist to complete the requested service.”
I had no issues uploading the files through the online portal. The Icedrive icon on my desktop still shows a red dot and “Icedrive: Upload is in progress” but there is nothing in the sync section when opening the software. There have been no other changes to my computer, storage or software.

I still have this problem with mounted drive! “no response to server”
I cannot save the files and my apps are freezing
What is going on Icedrive?

Many of us are having the same issue… Please, you check this update. It’s not working properly…

1 Like

Same problem here, freezing on Windows 10. I’ve gone back to previous version.

So that we can identify the issues that are causing this, would it be possible for all who are experiencing the issue to submit a support ticket and email the drive app log to support@icedrive.net?

You can access the drive app log via the following pathway;


Hi - I tried to email the log file but got an error saying that the email was too big. The logdata.txt file is 11.8 MB

Do you have any suggestions? I could put the file in a drive and share the link, just not sure if that will trigger a spam alert in your email?

Haven’t updated to 2.73 yet, so can’t comment on bugs. But… dev team, can you PLEASE make it a consistent general practice to post the release log for new versions BEFORE pushing the updates in app? I got the notification to update to 2.73 and went to this forum to see the changelog first and decide if I wanted to update. There was none. So, no update. Now that I see this, I’m glad I chose not to. Closest thing to a changelog is this user-initiated thread reporting bugs. This is not the first time this has happened. It’s unfortunate that I and apparently many other users no longer trust updates. This is not a good look for IceDrive. Please test new versions more thoroughly before releasing and do more bug squashing. Please release changelogs before pushing users to update. And please do not constantly rely on v3 as the go-to excuse for all v2 problems. Please, please, please, do better.


Wait a Minute!!! So I was not the only one who was facing these issues? I thought there was something wrong with my PC. And my file transmission was so slow it started to freeze even my word files.

Thank you Tambo for this clear words,
I am too frustrated at the moment to communicate it!