[Resolved] Has anyone had icedrive blocked in their browser?


Icedrive works great on all of my devices except one pc. I tried every suggestion I could google but finally decided to write it off. Then I sent an Icedrive link to someone and they had the same problem.

I assume the problem is with the individual devices, but I feel I have to be careful who I try to collaborate with using Icedrive until I know how to fix this problem when it happens.

1 Like

Interesting. Is it just the Icedrive website on this particular pc?

Usually these things can happen if the date and time on your pc is wildly incorrect

1 Like

Right, just anything to do with icedrive.net on just the one pc for me. And the gentleman that I tried to collaborate with using a link.

I’ve checked the time and many other common fixes. The only thing that works is a reboot. Then I’m able to initially access Icedrive. About 10 clicks around Icedrive and it returns to blocking the site.

1 Like

Interested to find out if this is happening to others, thanks for reporting. If you have any extended info on the error, or next time it happens you can paste it here, thatd be great!

1 Like

I have no issue getting to that page.
Can you click on the “Advanced” button and let us know what is says? (copy the full message)

1 Like

Hi Dan, like you I don’t have issues getting to that page on any of my other devices including a different pc. On the one pc when I click on advanced, I get

Then clicking on 'proceed (unsafe) I get

Chome - click on proceed_unsafe

Hi Jimmy, you can see my reply to Dan for screenshots.

I’ve tried many of the fixes recommended in google searches including: (4) different browsers, make sure time is set correctly, clear browser cache, flush DNS cache, change DNS servers (preferred 8 8 8 8, alternate 8 8 4 4), use certlm to check for multiple instances of Trusted Root certificates, look for malware, use http instead of https, use the IP address instead… I think many more that I cannot remember.

Even “go to the site anyway (unsafe)” or allow unsafe content in Chrome doesn’t work. As I mentioned, a reboot fixes the problem temporarily.

SSL Checkers show a Cloudflare server with a certificate issued by Baltimore CyberTrust Root. I have a Baltimore CyberTrust Root certificate in my Trusted Root Certificates folder and made sure that the settings (Certificate purposes and Extended Validation) were the same as the laptop pc that is working.

That looks like its blocked on some kind of parental safety browser or something - The certificate is coming from echo.remote.management - No idea what this is

I can assure you that “Access to this website has been blocked” is nothing to do with us and can only be outputted by a different server not owned by us - it does seem like something is intercepting your connection to icedrive.net on that device - The question is what and why

1 Like

I think you are onto something. “echo.remote.management” shows up a lot, using “find on page” at https://raw.githubusercontent.com/badmojr/1Hosts/master/Xtra/hosts.win

remote.management has something to do with SolarWinds MSP.

SentinelOne is affiliated with SolarWinds MSP.

SentinelOne is on my pc that gets blocked, but it is not on my other devices that work.

The person who also had trouble with the link sent this screenshot to me

image

The bigger problem for me is that, even if the problem is on the other end (like it looks to be with me) I will still look like I’m the one sending a suspicious link.

Disclaimer, I really don’t know much so I hope this information helps someone that does. Sorry for the long post.

1 Like

It’s working great now. Thank you for your help. Can the title of this be edited to add - Resolved?

Glad to know that its working. I will edit the post for you :slightly_smiling_face:

Hi. I’ve got a client who’s having the same problem you describe - they just get a ‘website blocked’ message but everyone else can get to the folder fine. Apologies I can’t quite work out what you did to fix the problem - did you have to remove some virus protection software? Many thanks.

Hi Gislon. Originally I thought I would just have to remove the virus software as you suggested. However, it then happened with someone else who was using a different virus protection. In my case I had to contact Icedrive. Icedrive was able to determine that they had been put on a list. It took a few days, but Icedrive was able to get their site removed from the list to resolve the issue.

It may be helpful to reply to Tom or someone else from the Team in his post above to let them know that you might have a similar issue to the one that I experienced. I assume they will also want you to open a ticket. I think that the more detail you are able to provide to them the better chance they will have to resolve the issue quickly.

1 Like