Icedrive wont allow change to its temp folder

error temp foder

Hi friends

I have over 400gb of files that are stored in my Icedrive account, and I need to extract them into another cloud storage folder that I have.
However, I only have 120gb of available space in my (C:) partition, and every time I try to extract the files, it crashes halfway through the process because Icedrive keeps filling the entire 120gb of free space I have in my (C:) partition with temp files.

I have tried everything I could think of. I checked the box where it says “minimize local disk utilization” this should disable the local disk cache and was supposed to fix the problem, but it does nothing at all.
I also tried to change Icedrive’s temp folder to another partition with larger disk space available, but after restarting Icedrive for the changes to be applied, I’m greeted with a message saying it couldn’t create the cache folder. I’ve attached an screenshot for reference.
I’ve created several tickets that went unanswered, and I’ve encountered many bugs and issues with Icedrive functionality, but right now I’m extremely disappointed with this situation, this defeats the entire purpose of having a cloud storage service in the first place.
Is there anything I can possibly do to extract these files without having Icedrive dumping all of its temp files into my main HD?
Any input is much appreciated.


The temp files are crucial to make everything run smoothly, of course when working with 400GB+ it will be a problem

There is a correct way to do this however, which V3 will start “outlining” more for user friendlyness

Here’s what to do to “bypass” caching

  • Go to the drive, find the folder, use context menu item “Download from Icedrive”

This will completely bypass the cache.

The reverse is also true for upload :slight_smile: